A kiválasztott modulnak nincs keresőindexe?

Szerző
Üzenet
kakaosital
Kezdő phpBB-s
Kezdő phpBB-s


Csatlakozott: 2014.05.01. Csütörtök 11:07
Hozzászólások: 26
Hozzászólás Elküldve: 2014.11.04. 17:23    Hozzászólás témája: A kiválasztott modulnak nincs keresőindexe?
Hozzászólás az előzmény idézésével
Jelenlegi fórum: 3.1.1.

Amikor belépek az adminisztrátori menübe mindig pirosan ez fogad:

Kép

Rákattintok, majd phpBB Native Fulltextnél nyomok egy "index létrehozása" menüt.

Kép

Lefuttatja, majd kiírja az indexelés sikerült, de továbbra sincs index (előzőeket töröltem, tehát az nem lehet probléma), illetve a a piros hibaüzenet fogad mindig. Miért van ez, illetve hogyan oldható meg?

Felhasználó profiljának megtekintése Privát üzenet küldése
Marcee
Adminisztrátor
Adminisztrátor
Avatar

Csatlakozott: 2006.01.17. Kedd 1:00
Hozzászólások: 2807
Hozzászólás Elküldve: 2014.11.05. 16:55    Hozzászólás témája:
Hozzászólás az előzmény idézésével
A Karbantartás fülön lévő Adminisztrátori naplóban vagy a Hibanaplóban nincs kapcsolódó bejegyzés? A Rendszer fül PHP információ pontban milyen érték szerepel a max_execution_time és memory_limit sorokban?

Nem biztos, hogy segíteni fog, de próbáld meg az includes/acp/acp_search.php-ben a

Kód:

var $batch_size = 100;
sor értékét ideiglenesen lejebb venni mondjuk 20 körüli értékre és úgy lefuttatni az indexelést.
_________________
Kérlek, privát üzenetben ne kérj segítséget olyan kérdéssel kapcsolatban, aminek a fórumon a helye!

Felhasználó profiljának megtekintése Privát üzenet küldése
kakaosital
Kezdő phpBB-s
Kezdő phpBB-s


Csatlakozott: 2014.05.01. Csütörtök 11:07
Hozzászólások: 26
Hozzászólás Elküldve: 2014.11.05. 17:52    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Ez van, ez 09.26., de ekkor még a 3.0.12.-es verzió volt

Idézet:

Általános hiba lépett fel: General Error
» SQL ERROR [ mysql4 ]

Got error 28 from storage engine [1030]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 240
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/db/dbal.php
LINE: 170
CALL: dbal_mysql->_sql_query_limit()

FILE: [ROOT]/includes/session.php
LINE: 971
CALL: dbal->sql_query_limit()

FILE: [ROOT]/cron.php
LINE: 156
CALL: session->session_gc()
Ez 10.02.

Idézet:

Általános hiba lépett fel: General Error
» SQL ERROR [ mysql4 ]

Got error 28 from storage engine [1030]

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

BACKTRACE

FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()

FILE: [ROOT]/includes/db/dbal.php
LINE: 757
CALL: trigger_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 193
CALL: dbal->sql_error()

FILE: [ROOT]/includes/db/mysql.php
LINE: 240
CALL: dbal_mysql->sql_query()

FILE: [ROOT]/includes/db/dbal.php
LINE: 170
CALL: dbal_mysql->_sql_query_limit()

FILE: [ROOT]/includes/session.php
LINE: 971
CALL: dbal->sql_query_limit()

FILE: [ROOT]/cron.php
LINE: 156
CALL: session->session_gc()
Ekkor már a 3.1 volt fenn, azóta frissítve lett 3.1.1.-re.

A 100-at levettem 20-ra de semmi változás.
A PHP alatt mindkét szám 30.

Felhasználó profiljának megtekintése Privát üzenet küldése
Marcee
Adminisztrátor
Adminisztrátor
Avatar

Csatlakozott: 2006.01.17. Kedd 1:00
Hozzászólások: 2807
Hozzászólás Elküldve: 2014.11.06. 21:05    Hozzászólás témája:
Hozzászólás az előzmény idézésével
A Got error 28 from storage engine [1030] üzenettel a MySQL általában azt jelzi, ha elfogyott a szerveren valahol a szabad hely. Azt kellene megnézned, hogy ha megpróbálsz újra indexelni, akkor is előjön-e ez a hiba. Mert ha igen, akkor az index adatai helyhiány miatt nem jönnek létre, és akkor ezt a hibaüzenetet a tárhelyszolgáltatódnak kell jelezned.
_________________
Kérlek, privát üzenetben ne kérj segítséget olyan kérdéssel kapcsolatban, aminek a fórumon a helye!

Felhasználó profiljának megtekintése Privát üzenet küldése
kakaosital
Kezdő phpBB-s
Kezdő phpBB-s


Csatlakozott: 2014.05.01. Csütörtök 11:07
Hozzászólások: 26
Hozzászólás Elküldve: 2014.11.07. 21:09    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Nem jött elő a hiba, de továbbra sem működik az indexelés.
Amúgy azon kívül, hogy jelen van ez a piros hibaüzenet valami problémám lehet abból, hogy nem működik?

Felhasználó profiljának megtekintése Privát üzenet küldése
Ragadozo
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2008.05.08. Csütörtök 18:26
Hozzászólások: 629
Hozzászólás Elküldve: 2014.11.07. 23:56    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Szerintem nálad is az lehet a hiba, mint ami nálam volt.
Azt hiszem, ettől működik az oldal, csak éppen a kereső nem fog soha kiadni semmilyen találatot.
A szerver php.ini fájlja nincs jól beállítva és/vagy az adatbázis tábla tárolómotorjának típusát MyISAM-ra kell beállítani.

Volt egy oldalunk egy free tárhelyen, ahol működött rendesen az oldal, de a keresőindexek nem mentek. Bár hibaüzenet nem volt (lehet, hogy azért, mert 3.0.12 volt a motor), de a jelenség ugyanez volt. Hiába futtattam le az indexelést, ami természetesen rendben lefutott, de a tábla tartalma továbbra is csak "0" eredményt adott.
Akkor írtam a szerver üzemeltetőjének, hogy milyen problémám van, és két-három beállítás sem tetszett a php.ini fájlban, ezt is jeleztem nekik (sajnos már nem emlékszem rá, melyek voltak azok).
A válasz az volt, hogy váltsam ki a valamilyen Pro csomagot, abban működik rendesen az indexelés! :(

Szolgáltatót váltottunk, egy-az-egybe felmásoltam az összes fájlt az új oldalra, egy-az-egybe megcsináltam mentésből az adatbázist, az összes adatbázis tábla tárolómotorjának típusát MyISAM-ra írtam át, 2-3 helyen átírtam a config táblát a szerver, az oldal, és a cache linkek miatt, majd bejelentkeztem.
Az AVP-be lefuttattam az indexelést, elsőre tökéletes lett!, és azóta sincsen semmi gondom vele.

Van itt is jó pár felhasználó, aki nálam jobban ért ezekhez, biztos tudnak segíteni, melyek azok a beállítások a php.ini fájlban, amik befolyásolhatják az indexelést.
Érdemes lenne ezeket (is) megnézni.

:)

Felhasználó profiljának megtekintése Privát üzenet küldése Email küldése Felhasználó weblapjának megtekintése
kakaosital
Kezdő phpBB-s
Kezdő phpBB-s


Csatlakozott: 2014.05.01. Csütörtök 11:07
Hozzászólások: 26
Hozzászólás Elküldve: 2014.11.08. 09:59    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Megnéztem a MyISAM a tárolómotor.

Igazából azért tettem fel a kérdést, mert tényleg zavaró, amikor az ember belép, s itt egy hibaüzenet. De, ha nem befolyásolja a fórum működését, akkor tényleg nem foglalkoznék vele, mert meg vagyok nélküle.
Amúgy van még négy indexelés, a legfelső a Native Fulltext. MIndegyiken tudok indexelést csinálni (persze töröltem őket, hogy tudjak a elsővel is), csak ezzel nem.

A 3.1 sem ment, de írtam a tárhelyszolgáltatónak, aki átrakott egy másik szerverre. Onnan meg sokat szöszmötöltem vele, mert ugye sablont kellett kicsit átalakítani, meg hasonlók. Szóval nem "szórakoznék" ezzel, ha nem muszáj.

Felhasználó profiljának megtekintése Privát üzenet küldése
Hozzászólások megtekintése:  

Nem készíthetsz új témákat ebben a fórumban.
Nem válaszolhatsz egy témára ebben a fórumban.
Nem módosíthatod a hozzászólásaidat a fórumban.
Nem törölheted a hozzászólásaidat a fórumban.
Nem szavazhatsz ebben fórumban.

Hirdetés
Hirdetés