Időzóna: (GMT +1 óra) RSS - hozzászólások

3.0 kontra 3.1

Szerző
Üzenet
Marcee
Adminisztrátor
Adminisztrátor
Avatar

Csatlakozott: 2006.01.17. Kedd 1:00
Hozzászólások: 2807
Hozzászólás Elküldve: 2015.03.15. 13:58    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Egy kis adalék a verziószámozáshoz:
A Symfony 2 a verziószámaik jelöléséhez Semantic Versioning-et használ: Our backwards Compatibility Promise. Ez röviden összefoglalva kb. annyi, hogy a verziószám MAJOR.MINOR.PATCH alakban épül fel, például 1.2.3 vagy 11.29.4.
Ebben a rendszerben a major számot akkor növelik, ha valami előző verziókkal nem kompatibilis, nagyobb változtatást vezetnek be. Emiatt ilyen változtatást csak kerek verziókban csinálnak, pl. 2.0.0, 3.0.0 stb.
A minor számot olyan új funkciók hozzáadásakor növelik, amik az előző verziókkal visszamenőleg kompatibilisek.
A patch szám növelésekor általában csak visszamenőleg kompatibilis hibajavítások kerülnek be.
További jelölések is lehetnek, mint pl. alfa, beta, rc1, rc2 stb., de nagy vonalakban ennyiről van szó.

A The Release Process oldaluk alapján az látszik, hogy új Symfony minor verziót félévente adnak ki, májusban és novemberben.

Én azt tartom valószínűnek, hogy a phpBB 3.1-3.2 és 3.2-3.3 között nem lesz akkora váltás, mint a phpBB 3.0-3.1 között volt, csak hozzáigazították a kiadási időpontokat a Symfony kiadásaihoz. A támogatási idők pedig azért ilyen rövidek, hogy egyszerre csak két támogatott phpBB verzió legyen. Elképzelhetőnek tartom, hogy a phpBB-nél is át fognak térni valamilyen semver-hez hasonló verziószámozási rendszerre, ezért nő ilyen tempóban a verziószám.


A Symfony alapok használatával szerintem több okból is nyert a phpBB:
  • Hirtelen lett egy csomó "másodlagos fejlesztő", akik ha egy phpBB által is használt Symfony komponensben javítanak valamit, akkor az a phpBB-ben is javul. Ez azon kívül, hogy "nem kell újra feltalálni a kereket" hosszabb távon a phpBB-ben karbantartandó kód mennyiségére is jótékony hatással lesz.
  • Sok nagyvállalatnál fáznak a gondolattól, hogy üzleti célokra használjanak bármilyen PHP kódot is. A Symfony-t fejlesztő SensioLabs és a Zend Framework-öt fejlesztő Zend Technologies egész üzletet tudott felépíteni a keretrendszerükre és az azokhoz kapcsolódó fizetős támogatásra, képzésekre, fejlesztői vizsgákra és hasonlókra. Ilyen alapokra épülve a phpBB bejuthat olyan helyekre is, ahova eddig kevés esélye volt.


A MOD-ok vagy kiterjesztések téma szerintem egyéni ízlés és megszokás kérdése, tény, hogy elég nagy szemléletváltás kell hozzá. De látni kell azt is, hogy változott a világ, amióta megjelent a phpBB 3.0.0. Akkor még éppen elképzelhető volt, hogy egy fórum tulajdonos útmutatás alapján beletúrjon a fájlokba, ha annyira változtatni szeretne az alap működésen, ma már ez sokkal nehezebben kivitelezhető. A mai standard fórum adminisztrátor csak ritkán rendelkezik komolyabb HTML, CSS és PHP ismeretekkel (ez egyáltalán nem baj), fájlokat még fel fog neked másolni a tárhelyére, de azokban turkálni valószínűleg nem fog (esetleg mással megcsináltatja). És a phpBB-nél ők teszik ki a használók nagy részét. Szerintem ezeknek a fórumoknak az üzemeltetését könnyebbé teszik a kiterjesztések.
(Ezt a MOD-kiterjesztés váltást -vagy valami hasonlót- a fejlesztők lehet, hogy könnyebben el tudták volna fogadtatni a 3.0.0 megjelenésekor az abban lévő összes többi változtatással, de most már eső után köpönyeg.)
_________________
Kérlek, privát üzenetben ne kérj segítséget olyan kérdéssel kapcsolatban, aminek a fórumon a helye!

Felhasználó profiljának megtekintése Privát üzenet küldése
pstvfan
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2006.07.30. Vasárnap 1:00
Hozzászólások: 1538
Hozzászólás Elküldve: 2015.04.12. 11:46    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Amennyire én tudom, a minor versionökben jönnek majd az új funkciók és a patch-ek csak bug fixeket és új event-eket tartalmaznak. Kompatibilitás szempontból elvileg két minor versionönként kell(het) majd az extensiönöket módosítani (tehát, ha az extensionöd működik 3.1-ben, akkor elvileg működnie kell 3.2-ben is, de 3.3-ban adott esetben némi változtatást igényelhet, mivel két minor version-nel később lesznek kitörölve a depracated függvények).

A váltások "méretéről" minor verziók között még talán annyit, hogy szerintem az egyetlen komoly változás a phpBB teljes életében az extension-MOD váltás volt. Ezt úgy értem, hogy ez volt (és nem is tudok olyan komponensre gondolni, amire ez még igaz lehetne) az a rész, ahol a felhasználók elveszítettek funkciókat. Például, ha mondjuk a phpBB core 3.3-tól más kóddal tölti fel az avatarokat, az maximum egy-két extension fejlesztőnek okoz pár óra munkát, a végfelhasználó úgyanúgy azt látja, hogy feltölt egy képet aztán jó napot.

A teljesítményről még talán annyit, hogy nekem nem tűnik túl vészesnek a teljesítmény vesztés, viszont amit cache-elni lehet, azt a phpBB core már nagyjából cache-eli, amiből az következik, hogy a phpBB már soha nem lesz gyorsabb, sőt a fájlok száma is csak nőni fog. Ez lehet, hogy rosszul hangzik, és csak "programozói előnyei" vannak, de szerintem azok igenis fontosak. A 3.0-s fájlok csak modokkal módosíthatóak, ezért fontos hogy a függvényeket felváltsák az autoloadable osztályok egyrészt. Másrészt a 3.0 core-ban még van egy csomó 2.0-s vagy régebbi kód, amiről szerintem senki sem tudja pontosan, hogy miért van ott, és egyeltalán szükség van-e rá. Tehát, a teljesetímény árán kapsz karbantarthatóbb, jobban optimalizált, és módosítható kódot.
Hogy a jól optimalizált kód miért lassabb, annak PHP interpreter működéséhez van köze, amiről tudjuk, hogy borzasztó (ha valaki nekem ezt nem nézi meg, akkor érdemes utána nézni pl. az HHVM történetének). Szóval szerintem elég valószínű, hogy előbb utóbb a PHP fejlesztők átveszik az HHVM fejlesztéseket, és az interpreter helyett a PHP is JIT ként fog működni, és akkor majd a jó kód gyors is lesz.
_________________
<M>

Felhasználó profiljának megtekintése Privát üzenet küldése
pstvfan
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2006.07.30. Vasárnap 1:00
Hozzászólások: 1538
Hozzászólás Elküldve: 2015.05.05. 19:40    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Btw, mindkettőből kijött egy új (csak azért írom ide, mert nincs a hírekben, és hátha valaki még nem tudna róla).
_________________
<M>

Felhasználó profiljának megtekintése Privát üzenet küldése
Mykee
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2005.08.29. Hétfő 1:00
Hozzászólások: 806
Hozzászólás Elküldve: 2015.05.07. 08:14    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Gondolkodom az átállás vs. 3.0 témán. Az egyik ok, amit korábban is mondtam, hogy kiderülhetnek újabb biztonsági rések, amiket a support vége után nem javítanak. Anno 3.0.12-nél kaptam azt, hogy "milyen biztonsági rés lenne már ebben a verzióban?" Hát lett, mert azóta kijött a 13-as és 14-es is. És ha kijön, akkor érdemes frissíteni, mert különben rárepülnek az illetéktelenek és kihasználják a rést.
Viszont a 3.0 frissítése nagyon macerás a sok mod miatt. Nálam legalább 60 különböző MOD van fent, ami miatt nem vezettem listát, hogy melyik fájlba nyúltam bele és melyikbe nem. Emiatt kissé nehézkes egy update, mert három fájl összehasonlítását végzem egyszerre: eredeti, új és a saját. Ahol van difi, ott kidobja, ahol nincs, az felülírható.
Mindezt vagy 4 fórumnál kell megcsinálnom. KillBill mester írta, hogy az autoupdate átírható, de a fentiek miatt a patchelés megírása és nyomozása (szerintem) legalább ennyi időt elvesz, mint a triós összehasonlítás.
A 3.1.0 szép dolog lenne, de itt meg egyrészt írtátok a teljesítménycsökkenést, de nekem nagyobb hasfájásom, hogy nem minden mod írható át extensionre, mivel inline-ban kellett belenyúlni, illetve van olyan kód, ami átívelő feltételt szab meg: fejben indul az if és a footerben ér véget. Ezt nem támogatja az extension. A nyitólapom például így cseréltem le saját oldalra: ha be vagy lépve látod a fórumot, ha nem, akkor a nyitólapot.
Plusz sok mod nincs megírva extensionre, például az egyik legtöbbet használt topic password, amiben a nehézséget a kereső találati listájának szűrése is okozza.
Tehát az átállással erősen csorbulna a manapság használt funkciókínálat.

Szóval nem tudom, melyik kezembe harapjak: a 3.0 frissítése macerás, a 3.1-en meg nincsenek meg a szolgáltatások és lassan itt a 3.2 is...

Felhasználó profiljának megtekintése Privát üzenet küldése
_zso2
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2006.07.25. Kedd 1:00
Hozzászólások: 2029
Hozzászólás Elküldve: 2015.05.07. 08:56    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Mykee, a Page-ekkel megoldható az egyik problémád (belépve fórum, kilépve oldal).
A többire sajnos nincs ötletem.
_________________
Tapasztalást pénzért venni vagy hagyományképpen kapni nem lehet - fizetni kell azért mindég és mindegyiknek.

Felhasználó profiljának megtekintése Privát üzenet küldése Felhasználó weblapjának megtekintése
Mykee
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2005.08.29. Hétfő 1:00
Hozzászólások: 806
Hozzászólás Elküldve: 2015.05.07. 09:09    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Igazából ha a Page-el ez megoldható, már előrébb vagyok, de esetemben az is kivitelezhető, hogy mindkettő index.php cím lesz? (Jelenleg így megy) :) Mert a Page-et eddig úgy tudtam, hogy akkor jók, ha önálló oldalt hozok létre a fórum mellett, de akkor újítottak a srácok?

Felhasználó profiljának megtekintése Privát üzenet küldése
Ragadozo
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2008.05.08. Csütörtök 18:26
Hozzászólások: 629
Hozzászólás Elküldve: 2015.05.07. 13:07    Hozzászólás témája:
Hozzászólás az előzmény idézésével

Mykee írta:

Gondolkodom az átállás vs. 3.0 témán. .........
Én már nem is gondolkodom rajta, döntöttem végleg, hogy marad a 3.0.1x
Nekem most jelenleg négy oldal van csak, és cca. 20-25 MOD van felrakva nagyjából oldalanként.
Viszont a MOD-ok mellett annyi rengeteg egyedi fejlesztés, módosítás van benne, hogy a jelenlegi körülmények között képtelenség átállni a 3.1, vagy újabb verzióra.
Már legalább a fele php fájlba bele nyúltam, és én sem vezettem naplót a változtatásokról.
Még mindig iszom a levét annak is, hogy nem találom, hova milyen limitet tettem, mert a képek feltöltésénél cca. 3.2 MB felett linkként jeleníti csak meg.

Sok olyan fórumot ismerek, amelyik hosszú évek óta megy szépen, és még mindig 2.xx verzió alatt fut.
Ez a 3.0.1x nekem valószínű még pár évig el fog ketyegni, aztán meg már csinálja majd tovább a jövő nemzedéke olyan verzióval, amilyennel akarja. :)

Felhasználó profiljának megtekintése Privát üzenet küldése Email küldése Felhasználó weblapjának megtekintése
Mykee
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2005.08.29. Hétfő 1:00
Hozzászólások: 806
Hozzászólás Elküldve: 2015.05.07. 14:53    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Én attól tartok, hogy a srácok a 3.2 megjelenésekor csak 3.1-ről engedik a migrálást, ergo, nem úszom meg a kétlépcsős átállást. :( Plusz a másik bajom, hogy a tárhelyszolgáltató pattogni fog, hogy ez nem supportált verzió, és ha bekapja a vírust miattam, akkor kirak. :(
Ilyen szempontok is nyomnak eközben és időben ezért agyalok, mit és hogyan kellene megoldani. Persze én sem állnék át, elég nekem évente egyszer is a kódokba beleturkálni, de a külső nyomás is nagy úr. :(

Felhasználó profiljának megtekintése Privát üzenet küldése
pstvfan
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2006.07.30. Vasárnap 1:00
Hozzászólások: 1538
Hozzászólás Elküldve: 2015.05.07. 16:21    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Szerintem 3.0.x-ről is fogsz tudni updatelni gyakorlatilag bármelyik 3.x-re. A fájljaid úgyis csak egyszer kell legyalulni és az a 3.0.x-ről 3.1-re van, szóval utána már az adatbázist bárhonnan tudod updatelni.
_________________
<M>

Felhasználó profiljának megtekintése Privát üzenet küldése
KillBill
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2007.03.26. Hétfő 5:42
Hozzászólások: 2237
Hozzászólás Elküldve: 2015.06.02. 11:17    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Na én rávettem magam, hogy frissítsem a support weboldalam, a frissítés egyszerű, ha betartod az utasításokat, nekem kb a feltöltéssel együtt 10 percembe került.

A saját stílus és a 15 MODs-átkonvertálása már más volt, az egy hetet vett igénybe :roll:

A frissítésem csak az új értesítés rendszernek köszönhető.

Két hibája van amit nem szeretek:
1. lassú a php legenerálása.
2. A kiterjesztések sorrendjét nem lehet beállítani. (Ha minden igaz ezt a későbbiekben korrigálják)
_________________
phpBB my addons: phpBB Arcade, [MODDB] phpBB Delete my registration, [RC] phpBB Invite
phpBB my Extensions: [RC] phpBB Arcade, [CDB] phpBB Delete my registration

Játék-világ - KillBill

Felhasználó profiljának megtekintése Privát üzenet küldése Felhasználó weblapjának megtekintése MSN Messenger
Ragadozo
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2008.05.08. Csütörtök 18:26
Hozzászólások: 629
Hozzászólás Elküldve: 2016.07.09. 10:24    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Na', én meg anno rávettem magam, hogy bizony én megmaradok a 3.0.x-nél.
Amikor bele néztem a 3.1 motorjába, struktúrájába, elszörnyülködve gondoltam arra, hogy mit érezhet a phpbb fórumot használni szándékozó fórum-tulajdonosok legalább 80%-a, akik még nálam is kevesebbet értenek a programozáshoz.
És még mindig azt érzem, hogy jól döntöttem! :)

Azon kívül, hogy a Social Network a felhasználók nagy részét "elcsábítja" a fórumozástól, brutálisan megcsappan azoknak a száma is, akik mostanság phpbb fórum motorral szeretnének fórumot létrehozni.
Ugye a phpbb az ígérte, hogy pár kattintással majd frissíteni lehet a 3.1 verzióra. Ehhez képest, akik kezdők, vagy kevésbé gyakorlottak, és phpbb 3.0.x fórumot üzemeltetnek, többségében képtelenek rendesen frissíteni a fórumot.
Nem is beszélve arról, ami a 3.0.x nagy előnye volt, hogy változtatni lehetett dolgokat, módjával, és kis hozzáértéssel bele lehetett nyúlni, egyedi megoldásokat lehetett létre hozni.
A jelenlegi körülmények között ezeknek a többsége kivitelezhetetlen, vagy legalább IT főiskolai végzettség kell hozzá.
Pedig pont ez volt az, ami igazán csábító volt, és a változtatások, újítások többsége azért jött létre, vagy azért készítették el a fórum tulajdonosok, mert valamilyen szinten, vagy valamiért szükségük volt rá.

Nem csak a magyar phpbb.hu oldal punnyadt be ennyire (heti talán?? 1 hozzászólás), és ez nem a nyári szünet, vagy nyaralási időszak miatt van.
Nézegettem a spanyol, német, sőt az angol phpbb oldalakat is, a látogatottság, a hozzászólások száma ott is brutálisan vissza esett.

A minap beszélgettem a fiammal (kint él Angliában már vagy 10 éve), és mesélte, hogy egy ottani számítástechnikai lapban olvasta pár hónapja, miszerint Európában a phpbb fórummotort használók közül nem éri el a 20%-ot azoknak a száma, akik átálltak a 3.1-es fórum motorra, és még ezek közül is sokan azt fontolgatják, hogy inkább megpróbálnak vissza állni valahogy a 3.0-ra.

Nem tudom, hogy mivel akarnak kirukkolni majd a 3.2 verzióval (vagy a lassan csak legendaként emlegetett 4.0-ás verzióval), de ha ezt a vonalat követik tovább, totál be fognak vele fulladni.
Lesz egy programozás-technikailag kétségtelenül jónak kinéző fórum motor, amit majd senki sem fog használni. :(

Felhasználó profiljának megtekintése Privát üzenet küldése Email küldése Felhasználó weblapjának megtekintése
pstvfan
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2006.07.30. Vasárnap 1:00
Hozzászólások: 1538
Hozzászólás Elküldve: 2016.07.09. 13:52    Hozzászólás témája:
Hozzászólás az előzmény idézésével

Ragadozo írta:

Azon kívül, hogy a Social Network a felhasználók nagy részét "elcsábítja" a fórumozástól, brutálisan megcsappan azoknak a száma is, akik mostanság phpbb fórum motorral szeretnének fórumot létrehozni.
Ugye a phpbb az ígérte, hogy pár kattintással majd frissíteni lehet a 3.1 verzióra. Ehhez képest, akik kezdők, vagy kevésbé gyakorlottak, és phpbb 3.0.x fórumot üzemeltetnek, többségében képtelenek rendesen frissíteni a fórumot.
Nem is beszélve arról, ami a 3.0.x nagy előnye volt, hogy változtatni lehetett dolgokat, módjával, és kis hozzáértéssel bele lehetett nyúlni, egyedi megoldásokat lehetett létre hozni.
Ez a kettő némileg összefügg, ha valaki az adatot módosítja, akkor valóban nehézzé, vagy lehetetlenné válhat a frissítés. Viszont, azok, akik nem piszkáltak bele különösebben a phpBB fórumok adatbázisában tárolt adatokba, az valóban könnyedén frissíthet, a probléma inkább az, hogy a telepített MOD-ok eltűnnek.

Ragadozo írta:

A jelenlegi körülmények között ezeknek a többsége kivitelezhetetlen, vagy legalább IT főiskolai végzettség kell hozzá.
Pedig pont ez volt az, ami igazán csábító volt, és a változtatások, újítások többsége azért jött létre, vagy azért készítették el a fórum tulajdonosok, mert valamilyen szinten, vagy valamiért szükségük volt rá.
Ez szerintem nem igaz, bár nyilván szubjektív, hogy kinek mi mennyire nehéz vagy könnyű. Az "Extension-öknek" sok előnyük van a MOD-okkal szemben, és ha engem kérdezel, akkor az egyik pont az, hogy könnyebb őket elkészíteni (ez nyilván vitatható) és karbantartani. Lehet, hogy ha megpróbálkoznál vele pozitívan csalódnál.

Ragadozo írta:

Nem tudom, hogy mivel akarnak kirukkolni majd a 3.2 verzióval (vagy a lassan csak legendaként emlegetett 4.0-ás verzióval), de ha ezt a vonalat követik tovább, totál be fognak vele fulladni.
Lesz egy programozás-technikailag kétségtelenül jónak kinéző fórum motor, amit majd senki sem fog használni. :(
Ha érdekel, hogy milyen a 3.2, akkor már le lehet tölteni az első RC-t. Az, hogy mikor jelenik meg a 4.0 és éppen akkor milyen állapotban lesz a motor, az némileg megjósolhatatlan (ugye eredetileg a 3.1 lett volna a 4.0, de a verzió számok megválasztása némileg furcsa).
_________________
<M>

Felhasználó profiljának megtekintése Privát üzenet küldése
Mykee
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2005.08.29. Hétfő 1:00
Hozzászólások: 806
Hozzászólás Elküldve: 2016.07.10. 12:14    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Én csak annyit tudok a fentiekhez hozzászólni, hogy
- erősen gondolkodom, hogy a 3.0 végleges lezárásával én is bezárom a négy oldalam javát. Konkrétan hármat.
- az extensionök nem minden esetben egyszerűek. Ugyanis amíg a 3.0 alatt egy mezőhöz felvettem egy feltételt és a functionbe egy meghatározást és kész. Na az extension esetében ezt nem tudom így megtenni, mert egy halom kódot kell megírni, plusz a végén jQueryt kellett használnom a mező letiltására, mert közvetlenül nem buherálható.
- van olyan extension, ami nem készült el, de az oldalaim java erre támaszkodik. Konkrétabban: a topik jelszó megadása a nyitónak. Anno félig készült el (keresés nem volt megoldva), aztán egy orosz oldalon még kalapálták a keresést, de ennyi. Nem írta át senki 3.1-re az elmúlt 2 évben. Pedig a tagok java emiatt van nálam, hogy zárt topikban fórumozhasson, kíváncsi szemek elől elrejtve.
- az egyik oldalam a játékokra épül, amit KillBill vitt tovább. Mivel a Flash is kifutóban van, lehet, hogy ezt már nem fogom frissíteni (már ha készült belőle extension, nem néztem).
- bevallom, nekem a keretrendszer és a funkciók még átláthatatlanok. Bár készítettem pár extensiont, amit itt is publikáltam, de már azokban is volt pár nekem logikátlan dolog. Nekem legalábbis nem volt pár dolog egyértelmű és mivel nem írtam sűrűn extensiont, nem vagyok benne, hogy mi kell és mi nem, hogy ne legyen optimalizálatlan.

Összefoglalva: tartok a 3.2-től, még ha nem is lett extension téren sok változás, de tény: ha kötelező lesz váltani, inkább lehet, hogy bezárom. :(

Felhasználó profiljának megtekintése Privát üzenet küldése
Ragadozo
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2008.05.08. Csütörtök 18:26
Hozzászólások: 629
Hozzászólás Elküldve: 2016.07.10. 20:16    Hozzászólás témája:
Hozzászólás az előzmény idézésével

pstvfan írta:

..........
Ez szerintem nem igaz, bár nyilván szubjektív, hogy kinek mi mennyire nehéz vagy könnyű. Az "Extension-öknek" sok előnyük van a MOD-okkal szemben, és ha engem kérdezel, akkor az egyik pont az, hogy könnyebb őket elkészíteni (ez nyilván vitatható) és karbantartani. Lehet, hogy ha megpróbálkoznál vele pozitívan csalódnál.
Nos', nem velem van a gond! :)
Én biztos, hogy nem fogok bele vágni, mert főleg azon az oldalon, ahol most vagyok, legalább 15 MOD van telepítve, és mellette van legalább ugyanennyi teljesen egyedi saját fejlesztés. Ráadásul a MOD-ok java része is át van írva az ottani igényeknek megfelelően, így ha valaki azt a MOD-ot 3.1-esre átírja, attól még koránt sem biztos, hogy nálam az működne.

Én azoknak a rengeteg fórum-tulajdonos felhasználóknak a szemszögéből nézem a dolgot, akik azért választották a phpbb 3.0-ás fórumot, mert még kezdő tudásukkal is volt lehetőségük egyéni dolgokat bele tenni.
Számukra ez most már eléggé kizárt dolog, kivéve, ha van egy jó haverjuk, aki ért hozzá, és baráti alapon megcsinálja neki.
Vagy fizet érte valakinek nem keveset, hogy elkészüljön.

Nézegettem azokat a tárhely szolgáltatókat, akiknél sablon-kész fórumokat lehet igénybe venni, például phpbb fórumot.
Lehet, hogy van, de én még nem találtam közöttük olyant, amelyik váltott volna a 3.1-re ....

Felhasználó profiljának megtekintése Privát üzenet küldése Email küldése Felhasználó weblapjának megtekintése
Mykee
Gyakorlott phpBB-s
Gyakorlott phpBB-s
Avatar

Csatlakozott: 2005.08.29. Hétfő 1:00
Hozzászólások: 806
Hozzászólás Elküldve: 2016.10.27. 08:11    Hozzászólás témája:
Hozzászólás az előzmény idézésével
Feltettem a 3.2 RC1-et és nézegettem, hogy milyen újdonságok lehetnek benne (mert nem találtam feature listát a hivatalos oldalon). Ahogy átfutottam az admin felületet, szinte semmi különbséget nem találtam a 3.1 sorozathoz képest. Motorban gondolom kalapáltak valamit, de feature-öben nem látok szinte semmi pluszt. Vannak vagy nagyon elrejtették őket? Fejlesztési szempontból láttam, hogy vannak optimalizálások (pl. eltérő szintaktika), csak "tudásilag"...?

A másik, amit még máig nem értek, hogy miért lett kivezetve a sablonszerkesztő a 3.1 verzióban. Párszor átrágtuk, hogy ftp módon oldjuk meg, de például pont pár napja nagyon jól jött a 3.0-ában, hogy mondjuk egy Title-t módosítsak. Egy fájlt sem kellett másolnom, csupán egy változót kellett módosítanom a sablonszerkesztőn keresztül és kész. Gyorsabb volt, mint a leszedés és töltögetés, cache törlés, stb. Emiatt erősen elgondolkodtam, hogy egy ilyen extensiont kellene kifejleszteni admin felületre, amiben egy fastruktúrás fájltallózó lenne (csak a sablonhoz!) mondjuk Codemirror editorral, de szép meló lenne...

Felhasználó profiljának megtekintése Privát üzenet küldése
Hozzászólások megtekintése:  

Időzóna: (GMT +1 óra) RSS - hozzászólások
Nem készíthetsz új témákat ebben a fórumban.
Nem válaszolhatsz egy témára ebben a fórumban.
Nem módosíthatod a hozzászólásaidat a fórumban.
Nem törölheted a hozzászólásaidat a fórumban.
Nem szavazhatsz ebben fórumban.

Hirdetés
Hirdetés